
Adr_Book Version 2.2 Step by Step

This document serves as a hands on tutorial of Adr_Book operation and as a general reference 
manual. By following the steps listed here you will quickly learn the operation of Adr_Book and 
its features. 

When you load Adr_Book the sample database file sample.adr will also be loaded.  This sample
file is required for using the step by step tutorial examples. 

NAVIGATION:  

1. Run the Adr_Book program.  If sample.adr  does not come up, click on file, and open the 
file sample.adr from the file menu. 

2.  Click on any tab letter to take you to the first entry of that letter. For example, click on the 
black and yellow F tab. You should see the name Furter, Frank appear in the upper left 
quarter of the address book. The name and address will be highlighted in turquoise. 

3.  The green arrows at the top of the screen move the highlight.  The single green arrow keys
move through the record names one at a time, while the double arrow keys move four at a 
time.   Using the mouse,  single click on the right green arrow. This should cause the name, 
Gardner, Richard to be highlighted. Click the single arrow three more times and you will see 
the page turn with the name Marx, Groucho highlighted.

4.  Any name can be brought up instantly by clicking on it in the list box to the right of the 
graphical address book.  Using the mouse, scroll through the list until you see the name 
Spaulding Roger.  Click on it with the mouse. You will immediately see the name appear 
highlighted in the upper left of the graphical display.

5. If you have many entries, the fastest way to reach a particular name is to drag the mouse 
over whatever name appears in the box above the list box.  When the name is thus 
highlighted, type the name you are seeking.  It will appear in the top left of the graphical 
display.  Type the letter M and you will see the name Main, Hugh appear highlighted in the 
upper left corner of the address book. Now type the letter A followed by an R.  The name 
selected will now be Marx, Groucho.   

6. Move the mouse to click on any part of the address within the graphical address book for 
Ramuglia, Randy. Notice how it now becomes the highlighted name. This is the means for 
making active any name visible on the address book.

EDITING /ADDING /DELETING and COPY:

1. Click on the A tab letter. Aile, Ginger should appear highlighted in the upper left corner of 
the address book. Using the mouse double click in any part of the turquoise area. This should 
bring you to Entry Form window containing all attributes for this record. Change the home 
telephone number from 9833 to 9888. Now click on OK and when the address book is 
redisplayed you should see this new home phone number.

2. Select the Edit button from below the list box. This will once again bring you to the Entry 
Form window. Click Cancel to go back to the address book. Now double click on the name 
Chu, Chirk in the list box. This also gets you to the editing dialog box. Once again select  
Cancel.  Now click on Edit from the pull down menu at the top of the window and select Edit. 
This is yet another way to get to the Edit Dialog Box. Select Cancel.  You can also type the 
accelerator key combination Ctrl+E to edit the currently active record.



3. Click on the A tab letter. Click on the Edit button to once again enter the Entry Form 
window. Click on the Add / Next button. This will cause the next record to be displayed, 
making it available for edit changes.  In this case, you will see the record for Chirk Chu.  Click
on the Add / Next button again and you will see the record for Scott Crevier appear. This is a
good way to go through all of your records making many modifications. Click on Cancel to get 
back to the address book display.

4. To add a new entry into the database click on the Add button below the list box. This will 
bring up an empty Entry Form. Enter your last name and first name and fields of interest. If 
this is the only name you want to add click OK to get back to the address book.  If you want to 
add additional records select  Add / Next. For our example, click on Add / Next.  Notice how 
the form is cleared and is ready to receive data for the next record. Click on Cancel. You will 
now see the name you just entered highlighted in turquoise.  You could also get the Entry 
Form for adding by selecting the Add option under the Edit menu option or by typing the 
accelerator key combination, Ctrl+A. You might note that you do not need to enter a starting 
capital letter for either the First Name or Last Name. Adr_Book always forces the first 
character of these two fields to upper case when the form is saved.

5. To delete a record click on the Delete button below the list box. Do this now for the record 
you just added. You will get a pop up box asking if you really want to delete the record.  The 
record to be deleted is the one currently highlighted in turquoise. In this case it should be the 
name you just added. Respond  by selecting Yes.  You could also Delete a record by selecting
the Delete option under the Edit menu option or simply by pressing the Delete Key on you 
keyboard.

6. The Copy selection under the Edit pull down menu will copy the name and address from 
the currently active record to the clipboard. This allows you to easily move names and 
addresses into your favorite word processor. You could try this now by first selecting Copy 
from the pull down menu. Then go to the Microsoft supplied Write or Wordpad program and 
select Paste from the Edit pull down menu.  You will see the name and address that was 
lasted highlighted in turquoise appear in your document.

DISPLAY OPTIONS:

The display options control what record information will be shown on the graphical address 
book. 

1. Click on the Option menu item and then select Display.  From the dialog box presented 
click on the Work Phone check box, and the Birthday check box.  Now click on the OK box. 
You should see the work phone and birthday appear in the graphical address book. 
Experiment with different data items that can be displayed.

2. The Notes free text information can be displayed from the graphical address book. To 
demonstrate this check the Note check box in the Display dialog box. (This may already be 
checked)  Click on OK to get to the graphical address book. Click on the A tab letter so you 
can see the Ginger Aile record. Notice the  word Note is highlighted in red.  This means that 
there is some free text associated with this record. If there is no Note text you will not see the 
highlighted Note.. word appear for the record. Now click anywhere in the red highlighted area. 
A pop up list box will appear, and for Ginger Aile you will see three lines of text. You can now 
click anywhere in the window and the list box will disappear. This is an easy way to bring up 
any additional information you decide to add for an individual.

REPORT OPTIONS:

The report options controls the text used for report headers and the return addresses to be 



used when printing envelopes.

1. Click on the Option menu item and then select Report Header.  The dialog box presented 
allows for two header lines to be printed on reports and two possible return addresses that can
be used when printing envelopes. At this time you can change these entries but they will not 
be used until later when printing is described.  If you make changes you must select either OK
or Cancel when you exit the dialog box. If you select Cancel any changes you have made will
not be saved.

MODE (USA/International) OPTION:

This option determines how the address portion of the record is formatted. USA mode has the 
address entry fields as two full lines of Address, a line for City, a place for State, and a place 
for Zip Code. International mode provides four full address lines, permitting the address to be
entered in any appropriate fashion. A single database file can accommodate both types of 
records.

1. Click on the Option menu item and then select Mode (USA/International).  This will bring 
up a dialog box that simply permits you to select a check box for USA or International mode. 
It also gives a rather winded explanation of the difference between the two modes. Click on 
the International mode check box. Then click on OK.

2. Click on the ADD button to create a new record.  When the Entry dialog box appears you 
will notice the Address entry block looks different. As described above, there are four full lines 
for entering the address. Go ahead and create a new record with any name. Then click on 
OK. 

3. Now you should see the new entry you created highlighted in turquoise. Get to the Edit 
entry screen by double clicking in the turquoise area. Notice that the address entry area still 
has four full lines (as you suspected).  Click on Cancel.

4. Now go to the entry screen of any of the other records in this sample database file. Notice 
how the Address lines have City, State, and Zip. Any new records that you add for now on will 
have the International style address mode. 

5. Click on the Option menu item and select Mode (USA/International). Click on the USA 
check box and then click on OK.  Now any new records that you add will have the USA 
addressing format.  Go ahead and select the Add button to see that this is true. Click on 
Cancel.

FILE EXPORTING / IMPORTING:

Import and Exporting is the process of exchanging data between application by way of text 
files. These text files are often referred to as ASCII files and contain separated text strings that
correspond to individual record fields. i.e. Last Name, First Name, Phone Number, etc. Most 
database and spreadsheet programs are capable of producing ASCII files containing their 
record information in separated fields.

The Importing and Exporting capabilities were greatly enhanced in Adr_Book version 2.0. It is
now possible to specify the ordering of the fields within the file, and what character or 
character sequence separates each field. By ordering we can say the fields in the file will be 
"Last Name", "First Name", "Birthday", "Home Phone" or "First Name", "Last Name",
"Home Phone", "Birthday". The field separator or delimiter indicates if a tab, comma, double 
quote comma, etc separates the fields within the file.

Importing data into Adr_Book implies merging data. If you already have 15 records in 



Adr_Book and you Import an ASCII file with 10 records you will end up with a database 
containing 25 records.

The Import command can also be used to merge two Adr_Book database files. Adr_Book 
database files end with a .ADR extension. This extension indicates that a database file rather 
than an ASCII file is to be merged. 

With that general introduction and overview behind us, let's step through some examples. The 
sample Import file, import.dmp, should have been included with your installation.

1. Start by selecting New from the File menu. If a dialog box asks if you want to save 
changes, click on NO.

2. Select Import from the File menu. From the dialog box select Setup. We now need to 
describe this Import file. It has only four fields for each record and they are in the following 
order: First Name, Last Name, Work Phone, and Home Phone.  Each field is separated with a 
tab character. (Feel free to view import.dmp with any text editor)

3. Click on the Tab Radio Button to indicate this is our field separator. Since this is the default 
separator it is probably already selected. Click on the First_Name in the Adr_Book Fields List 
Box. It should become highlighted. Since this is the first field in our import file click on field 
<01> Skip of the Import File List Box. You should see First_Name copied into the Import File 
List Box. Next, click on Last_Name under the Adrbook List Box. Move this to the Import List 
Box by clicking on field <02> Skip. Move Work_Phone to field <03> Skip and Home_Phone to
field <04> Skip in a similar fashion. You have now described the format of the sample Import 
file. Click on OK.

4. You should now be back at the previous dialog box. Click on open. In the Open Dialog box 
that is presented you should see the file Import.dmp. Select this and click on OK. You should 
now see that four names have been added into Adr_Book.

Before leaving this section I want to demonstrate how database files can be imported. 
Database files are files like sample.adr. Files that have .adr extensions. As mentioned above 
Importing implies merging. This will demonstrate how you can merge multiple .adr files. 

5. From the File menu select Import. Next click on Open. Down by List Files of Type click on
the down arrow.  You will see an entry Database Files (*.ADR). Click on it. You should see the
database file sample.adr. Select this and click on OK. You should now see that the 
sample.adr database file has been loaded and merged with your previously  imported 
records. You can use this method to merge any number of database files. I should point out 
that this is a little bit of magic. The .adr file extension indicates to Adr_Book that a database 
file is being imported. Any setup for importing files is ignored. If interested there is also a 
section in the On-line Help titled Merging Database Files that also explains this process.

6. There are some limitations on importing data. You can only import approx. 300 records at 
one time.  If you have more than this to import you will need to break data into separate 
blocks.  Also note that after you have imported 300 records, you must Save the file and then 
Open the file again to reload it into Adr_Book. This is important or you will likely get a stack 
overflow error. 

7. Lets clean everything. Simply reload the sample.adr file by selecting Open from the File 
Menu. Select No when asked if you want to save the changes. Click on sample.adr and then 
select open. 

I am not including a detailed description of the Export process but it is identical to Importing 
except that your database file will be written to an ASCII file based on fields that you select 



and the specified field separator. There is one thing that should be noted about this Export 
process. If you select a subset of your database using the Find feature (described below), 
only those records currently selected will be written to your Export file.

FIND:

The Find feature of Adr_Book is a means of locating an individual record or a group of 
records. The find feature of Adr_Book works a little differently than the find feature in many 
other applications. Rather than simply locating the first record that meets a search request, 
Adr_Book will present at once all  the records that met a given search request. For example if 
you had 500 records in your database file and a search matched 50 records that had a ZIP 
CODE starting with "995" the address book would now display only those 50 records.  This 
has implications for printing.  Printing labels after the search just described would result in only
50 records being printed. Those 50 records that matched a ZIP CODE starting with "995".

There are two modes to the Find command. There is the Basic method and the Complete 
method. The basic method is the default. You can specify which method to use by selecting 
Type under the Find Menu Option.

The basic method can be used for most needs. For example if you entered the words 
"Christmas Card" in the notes field for some of your records you could locate all of these 
records by simply searching for the string. You would be presented with the list of records that 
contain the string. You could then print labels for only those records. Enough talk. Here is a 
small example of the Basic Method.

1. Select the Find Type.. from the Find menu.  If the Find Basic is not checked, click on it 
and select OK.

2. Select the Find... from the Find menu.  You could also use the Accelerator Key Ctrl+F. This
will bring up the Find  Simple Dialog Box.

3. In the Find What entry type 99.  Select the Starts With  from the drop down box of the Find 
if... question.  Check the Home Zip check box.  Click Find It.

4.  You should see three names in the graphical address book.  

5. Select the Find... from the Find menu. Now select Contains from the drop down box of the 
Find if... question, and click on Find It.

6. This time you should see four names in the graphical address book.  We picked up the 
additional name, Rhoda Train, because her zip code ends with 99.

7. Now type Ctrl+L to clear the results of the search command. This will bring all 18 records 
back into the Address Book.

The complete method allows for two additional methods of locating records not found in the 
basic method. 

The first additional feature is the ability to search only in records from a previous search. Here 
is a real world example that doesn't make a great deal of sense but will demonstrate the 
principle.

7. Select the Find Type.. from the Find menu.  Click on the Find Complete check box and 
then click OK.



8. Select the Find... from the Find menu.  You could also use the Accelerator Key Ctrl+F. This
will bring up the Find  Complete Dialog Box.

9. Enter 33 in the Find What field.  Click on the Home Phone check box. Also, click on the 
Home Zip so the zip field wil not be searched. You want to be sure to remove the X from zip 
check box.  Then click on the Find New button.

10. The result will show that 3 records have been found.

11.  Get back into the Find Dialog box.  Enter 6 in the search field.  This time click on the Find 
Subset button.  What happens now is that only the 3 previously records found will be 
searched for a 6 in the Home Phone field. You will only see one record displayed. Go ahead 
and see what the result would be if you put 6 in the search field and click on the Find New 
button.

The most powerful method for defining what records are to be displayed comes through the 
Flags Detail.  This requires you set up predefined single character letters to Flag your 
records. 

12. Get back to the Find dialog box.  Now click on the Flags Details button.  This will bring 
you to another Dialog box. This is a special search that will only search the Flags field in each
of your records. The search will be case sensitive. This means that a capital A will be different 
from a lower case a. This has the ability to search for OR conditions. That is what we will do in
our example.

13. Enter a lower case r and a lower case t in the entry field.  Then click on the OR check box,
and the click on OK. 

14. Now you are back at the first dialog box.  You have to be a little careful at this point. If you 
have any other search condition in this dialog box and click on Find New, it is that search that 
will be made and records displayed for.  If you have been carefully stepping through this 
example you will currently have a 6 in the search field and the Home Phone checked. If you 
click Find New at this point it is those records you would find. You can do a couple of things 
here.  You can click on Cancel. This says don't do this search and only show me the records 
from the Find Detail search. Go ahead and do this.

15. In the Address Book display you will see that 7 records have been located. If you examine 
all of these records you will see that each one of them has either an r or a t in the Flags field 
of the record.

16. Now go back to the Find dialog box.  (Do not enter Ctrl+L before going to the Find Dialog 
Box).  Once in the dialog box put a 6 in the search string and check the Home Phone check 
box.  Now click on the Find Subset button. 

17. You should now see two records. If you look at the details of each of these records you will
find that they have either an r or a t in the Flags field and a 6 in the Home Phone field.

All of this combined together allows for very powerful record selection cabability. Also not that 
in the Flags Detail you can also do searchs for And. In the case of r and t this would mean 
that the record must contain both of these letters in the Flags field before the record will be 
identified. You could also select the NOT check box and in this case you would get all the 
records that DO NOT have an r and t in the Flags field. 

To get all of the records back,  type Ctrl+L.

DIALING:



Phone Dialing was a new feature to Adr_Book version 2.0. It is necessary to activate this 
feature before you can actually click and dial. Once you have set up this feature, clicking on 
any Yellow and Black phone number in the address book display will initiate a call.

1. Select Setup (currently your only choice) from the Dialing Menu. Select the radio button 
associated with the COM port of your modem.  Baud rate really shouldn't make any difference.
The default for the modem Initialization string is ATZ.  This should actually be just fine for 
most modems.  If your mode fails to dial you might try simply removing the ATZ and leave the 
field empty.  If you modem still fails to dial you will need to consult your modem manual for the
proper initialization characters.

2. If you need to prefix all numbers with nine (9) or some other number to obtain an outside 
line you can enter this in the box provided. For purposes of demonstration enter a 9 of the 
prefix box. There are two other fields that you can enter other numeric strings. They are 
simply listed as Option #1 and Option #2.  These strings will be used at the time that you dial 
a number.  The default for Option 1 is "1", which can be used to dial a long distance number. 
Option #2 has the value of "011" which can be used for dialing an international number, at 
least from the United States. You can put any numbers in these boxes.  They can be used for 
entering your dialing card number etc.  If you need pauses in the number these can be 
accomplished by putting commas (or whatever your modem supports).  These two Option 
fields can hold 25 characters each.  For the purpose of this demo you should leave them with 
their default values.

3. To actually enable the click and dial feature you must select the Enable Dialing check box. 
Click on the Enable Box at lower right. Then click on OK.

4. You should be back at the Address Book display and all you need to do now is click on any 
Yellow and Black to activate dial. For a good example click on the "A" tab to get to good old 
Ginger Ale. Click on the (907) 673-9833 phone number.

5. A dialog box should appear with the number you selected. You should see that a 9 prefixes 
the telephone number. The number in the text box is the actual number that will be dialed 
once you select the Dial Number.  Should you ever need to modify this number  for any 
reason you can do so in the text box. If this really was a long distance number that needed to 
be dialed it would need to be prefixed with a 1.  A method has been provided for this. Click on 
the Add/Remove Option #1 check box. You should see the number 1 inserted after the 9 but 
before the 907 area code. If you once again click on the Add/Remove Option #1 check box 
you will see that the number 1 is removed.

6. There is also a check box for Option #2 and Area Code. These operate in a similar fashion
for inserting and removing numbers to appropriately form the number you need to dial. You 
can select these to see how they work. The intention behind all of this is to allow you to keep 
your phone number in your database the way you would like it to print in reports or address 
booklet, and at the same time easily use the number for dialing. If the dialing feature is more 
important to you than printing reports, then simply store the number exactly as it should be 
dialed so no changes are needed when you dial.

7. Go ahead and click on the Dial Number button. Another dialog box will appear telling you 
that it is dialing the number. If you were dialing a real number you would wait until the number 
is dialed, then pick up your phone and click on Cancel.  (For right now it might be wise to very 
quickly select Cancel. :-)

PRINTING:



The real test of this program working for you is how well it prints name lists, the address 
booklet, labels, and envelopes.  Before you consider registering this program run through all of
the printing options to see that all works well for you. Turn on your printer!

For all printing options only the records currently being displayed will be printed.  As described
above, if you have used the Find command to select a group of records, then only those 
records will be printed.  This is actually a powerful feature method for printing sets and groups 
of records.

1. From the File menu select Print.  From the dialog box select Print List Two Columns. 
Then click on OK.  This report will only print individual names and a phone number.  Also as in
all reports you can specify how many copies and a header to be printed.  The unique option 
on this report is whether to print the home phone or work phone. Click on Print and see what 
happens.

2. From the File menu select Print.  From the dialog box select Phone List (condensed ..) 
Then click on Print. This report will print the name, address, and the home and work phone 
numbers. It will print both the home address and work address if present. Click on Print.

3. From the File menu select Print.  From the dialog box select Pocket Size Address Book. 
Then click on Print. The default setting is to print an address booklet with pages that are 4 
1/4"  x 5 1/2 ".  There are several other booklet sizes to choose from.  If you choose a smaller 
size, you will most likely need to choose a smaller font size to assure that all data is properly 
printed on your booklet.  The smallest size fits nicely in your shirt pocket. You also have the 
ability to select which fields of the record should be printed. The default is to print all fields, but
if you only wanted to print home and work phone numbers this can easily be accomplished.  
To work correctly your printer must be able to sheet feed since printing is two sided. Click on 
Print. For this example, one sheet will be printed and a dialog box will appear asking you to 
reload the paper to print on the reverse side. Do this and then click on OK.  Take the paper 
and cut it in half so you will have two sheets that are 4 1/4"  x  5 1/2".  Stack them so that the 
sheet with number 1 will be on top of the sheet with number 3. Fold it in half and you will have 
a small address book.  This address book will be created correctly for any number of records.

Version 2.2 also allows for color printing of the address booklet. Even if you don't have a color 
printer today, you might want to look at this feature because you will likely have one some day.
If you do have a color printer, you will really enjoy this. From the Pocket Size Address Book 
dialog box select the Color Setup button. This will present a dialog box that allows you to 
define the color for each field that is printed in the booklet. First click on the color you would 
like to set and then click on any of the text in sample output or the right hand side of the dialog
box. The text will change to the color you have select. This will then be the color printed on 
your address booklet. 

4. From the File menu select Print.  From the dialog box select either 2-UP Labels or  3-UP 
Labels. Then click on Print. You will then be presented with a dialog box permitting you to 
select whether the addresses should be home or work, in order by zip code, all capital letters. 
There is a Position ... button that will take you to a dialog box to allow positioning of labels for 
output. Click on Print.

5. From the File menu select Print.  From the dialog box select any of the three Envelope size
options. Then click on Print. Envelopes can be printed in Landscape or Portrait mode. 

The first thing you should notice in the dialog box is the Addressee contains the name that 
was highlighted in turquoise on the graphical address book.  There are a variety of options 
from this dialog box. From above, you had the opportunity to enter two return address in the 
Options  Report Header dialog box.  You can now toggle between these two preset return 
addresses by clicking on #1 or  #2.  You can also perform editing in the return address 



displayed to change it to any desired return address. ( You can also edit the addressee text). 
There are the usual options of fonts, point size, bold, and Italic. Have fun and create an 
attractive envelope. You can also choose to have the postnet barcode printed for the zip code.
To have a note text printed on the lower left of the envelope you will need to click on Note... to 
get to another dialog box for this purpose. When you are though click on Print to see the 
result.

Note: printing envelopes is actually a very tricky business. There are several check boxes that 
allow you to specify printing on the left, right or center of the print tray, and whether to print in 
the front or rear. Basically if you have a LaserJet the defaults of This side and Front should 
work fine. For a DeskJet select The Other Side and Rear.  You can also select whether to 
print in Portrait or Landscape. Hopefully you can find some combination that will work 
successfully with your printer.

If you have stepped through this document you will have tested most of the features of Adr_Book
and should know if this program will work for you. I hope that it will. If you have any questions or 
suggestions please send to me at:

Internet E-mail to mikeg@alaska.net  (This is actually the best way to contact me)
Alaska phone number (907) 278-1231

Michael Gardner
1231 Redwood Ct.
Anchorage AK 99508

Also be sure to check out the Brown Bear Software home page at:
http://www.alaska.net/~mikeg

This homepage can always be used to find out about the latest developments.

March 11,  1996


